折腾了好长时间才安装好,主要是scipy的问题。

安装依赖

sudo apt-get install python3-dev
sudo apt-get install libblas-dev liblapack-dev libatlas-base-dev gfortran

安装numpy和scipy

这两个库都是scikit-learn必须的,前一步的依赖几乎全都是为安装scipy作准备。

pip install scipy
pip install numpy

安装scikit-learn

官网的要求:

  • Python (>= 2.6 or >= 3.3),
  • NumPy (>= 1.6.1),
  • SciPy (>= 0.9).

安装实际上很容易:

pip install scikit-learn

提示success就可以在python里import试试看啦!

参考:

Installing scikit-learn scikit-learn 0.16.1 documentation
python - Installing SciPy and NumPy using pip - Stack Overflow