提示没有编译器

需要安装gcc:

sudo apt-get install gcc

提示Python.h: 没有那个文件或目录

如:

plugins/python/uwsgi_python.h:2:20: fatal error: Python.h: 没有那个文件或目录

可能是因为环境不完整,考虑安装如下两个包:

sudo apt-get intall build-essential
sudo apt-get install python3-dev

注意:如果用python2的话上面那个包换成:

apt-get install python-dev